how to mend it - Fix appliances, electricals, gadgets, cars... Ask for free help
:: home
:: add a question
:: search
:: help
:: most recent
:: unanswered
   Search: Go 
Fixed for free!
Ask Your Question
Popular

These categories may also be of interest ...

Kitchen Appliances, Gas Cookers

Kitchen Appliances, Juicers

Kitchen Appliances, Refrigerators

Kitchen Appliances, Toasters

Kitchen Appliances, Waste Disposal Units

Full list

... mend, fix, or repair just about anything.

Help someone
  Are you good at fixing things?  

Click here to help

Fault info.
Click here for Sunbeam repair information.
First time?

howtomendit.com costs nothing to use and you can ask a question without an account or logging in.

Click here to ask a question.

Answers

Who answers the questions?

Other users of howtomendit.com provide the answers. The more detail and information you provide in your question the easier it is for others to help you.

Search for a fix
How can I fix my
Microwave?
Mend it
How can I repair my Peugeot 406?
Categories > Mend Kitchen Appliances, Microwaves > Question
Q & As - mend, repair, fix kitchen appliances, microwaves, microwave, turn, table, turn-table, bell, burn, fire, light, watt, radiation,Navigate to ...
Kitchen Appliances, Microwaves (2461 other questions)
Related questions - kitchenaid, oven, problem
Add a question



Mend > Microwaves

Question - mend, repair, fix

Kitchenaid KEMS377 Oven Probe Problem?

This is the double wall unit, microwave on top, convection/traditional oven on botton. We don't have the oven probe. The oven thinks the probe is plugged in--the probe signal is on. The oven won't work because it thinks the probe is plugged in. When we try to start the oven, the display reads, "pull probe out".
We have turned the unit off (via the fuse box, so it's OFF), several times for extended periods, and the problem still doesn't go away. I've tried cleaning the plug where the probe is inserted, but nothing. A call to Kitchenaid's 800 number got us the great advice to call a certified repair man. We know that means big bucks. Anyone else had this problem? We're without an oven until solved. Thanks!



Billy
August 2008


There is more help available. Mend - kitchenaid, oven, problem
Need to mend your KitchenAid microwave?

To add an answer, click here To add a new question, click here To find all other questions, click here

Answers - mend, repair, fix

Kitchenaid standalone electric stove/oven. same issue, wife was boiling shrimp and it overflowed. remove probe message would not go off even after extended power loss. (unplugged stove). Fix was inserted probe, set probe temp to 160, left probe dangling out side of oven. selected convect bake at 450 degrees for about 20 minutes after oven reached temp of 450. turned off oven and removed probe. message went out within a minute later. thanks for all the posts here. (it takes a village). :). Love my Kitchen-Aid stove and would buy another one without hesitation.

Happy again
May 2018

I just left the oven door open overnight and I guess the sensor dried out so when I woke up in the morning the light went out.

I should note mine went on when I spilled some water on the stove top and it steamed up. I think the steam may have made its way under the edge of the control panel where it meets the glass top and that's what set it off.

Al G
March 2018

Same solution worked!! Never have used probe in all these years (oven is 11 years old), but tried it for Christmas dinner. All went well until a week later, we heard beeping and noticed the probe request, which baffled us because the oven was not in use at the moment. Set plugged in probe to 160, removed it quickly and set oven to Bake at 400 for 20 minutes.

Jen
December 2017

Baked chicken and vegetables today and had "enter probe temperature " display when I tried to turn off the oven. Couldn't get rid of the display, couldn't turn off the oven, no solution in the manual. Have never used the temperature probe! Tried the suggestion I found here and it worked! Entered probe temperature of 160 then set the oven to 400 and let it run for 30 minutes, then turned it off.

Bernadette
July 2017

Hi Everyone,
I used the hairdryer to dry out the probe outlet. I could not turn on my kitchenaid oven at all to dry it out. this is really a design flaw. Thanks for the solution.

https://www.youtube.com/watch?v=12bsYMqUNTg

Cat
November 2016

Trying the method suggested below but I want to tell anyone reading this who HOPEFULLY had not yet purchased a Kitchenaid oven. DON'T BUY ONE!!

Ours came with our house when we bought it and 6 months afterwards we went to use the self cleaning feature which promptly fried the fuse. We have a home warranty so the guy came out for $60 and replaced it (we had to wait almost a month).

6 months after that, we tried to self clean again and THE SAME THING HAPPENED! Another visit from the home warranty and another $60. This would have cost hundreds if we hadn't had the home warranty. The second guy to come out told us that it is a huge and common issue with Kitchenaid ovens of this type. A simple google search will verify this.

So we've been hand cleaning the darned oven ever since and today I guess something happened and maybe the probe nozzle got wet or something and now it's stuck in probe mode. AND WE DON'T EVEN HAVE THE DARNED PROBE! It's just the part that's permanently fixed into the back of the oven. Here's to hoping it resets.

Mike
February 2016

It worked!!!! heated oven to 350 degrees, probe light went off within 10 minutes. Yeah!

Marilyn
January 2016

Having the same problem, also the F3 E3 error happened first. It was all due to cooking chicken slowly creating a lot of steam.
First time happened a year after purchase and again just last week.
KitchenAid will not do anything since it is past the one year warranty. It is not even 2 years old.

My oven is the 27" Convection Built-in Oven. Model KEBS179BBL

Important for people to know the bad quality products and poor customer service that KitchenAId provides. Buyer beware.

Margaret
December 2015

None of these have worked for me…any other suggestions?

Frustrated Cook
November 2015

All great advice! Had probe error yesterday after roasting a turkey. Without the probe in the oven, we set probe temp at 160 and oven temp at 400 for about thirty minutes. When we shut the oven off, the probe requests were still there. We opened the door. The fan continues to run. After about ten minutes the probe requests disappeared, and everything is fine now. Thanks, everyone!

Don Edwards
November 2015

Thanks to all who provided the solution. This regularly happens to us with our Kenmore Elite Model 790.4500 Induction Stove. We have a meat probe but we have never used it. I have a related question. I have been looking on the web for 30 minutes for some type of dummy plug I could insert into the meat probe receptacle to disable it. (I realize I could cut the wires to disable it, but it seems like a dummy plug to keep the moisture out of the receptacle would be easier.) Has anyone found anything, or tried to fill the receptacle with something that is not flammable? Thanks.

Joel Angiolillo
September 2015

Don't have a Kitchen Aid but a Bosch built-in oven that had the "remove or set probe" message, and we had never even used the probe before and it wasn't plugged in of course. The oven could still be used on bake or convection settings by hitting down arrow to probe temp and then up back to oven temp which then strangely allowed oven to be started by hitting "start" after picking desired temp. Assuming the problem was moisture as was mentioned here, set the oven at 350 degrees for half an hour but that did not work. Then we shut down the power to the oven and restarted it and now the message is gone and it works normally.

J. Cruz
September 2015

7 years later and Kitchen Aid is still non responsive. Thank you so much for this post and the comments. Setting probe temp to 160 and htting Bake then 400 did the trick. What a RELIEF. Silly me for cleaning my oven by hand.

Smartina
May 2015

Thanks again -- I had the same problem, and indeed entering a probe temperature of 160F, and selecting Bake, and 400F, and running it for 15 minutes after it reached temp did the trick!

PghMike4
March 2015

Thank you so much for the bow dryer suggestion. I was wiping my oven tonight and the mystery probe message came on. Of course it wouldn't allow my oven to work and I am having a dinner party in my home this weekend. You saved me from a service call and having to take the day off from work

Relieved kitchen aid owner
March 2015

Thank you so much for the hair dryer fix!!! Totally worked, thank goodness :-)

Coleen
January 2015

I have a Kitchenaid Superba Slide in Range with the same "probe in" problem. This is VERY SERIOUS my range computer panel changes the temperature from whatever its set at to 600* F all on its own then runs through a range of probe problems then shuts off and turns back on all by itself. If this fault you all have is not corrected with using a blow dryer to dry out the probe housing then you need a new circuit panel control board or you can cut wires 4 and 5 on the panel controlling the meat probe . I suggest that if you have this problem and don't replace the circuit board SHUT OFF THE BREAKER so your oven doesn't come on by itself like mine. Also Google www.kitchaidfire.com for a class action suit about their products catching on fire. Whirlpool knows and will Not put out a recall or fix these appliances. Also report your problem to the consumer product safety commission. www.cpsc.gov/en/ FIRE HAZZARD, beware!

FloridaGirl
January 2015

Had the same problem with KEMS379, message saying remove probe or set probe temperature, but had never used the probe. Happened after we cooked a turkey for many hours at low temperature (250 degrees). Moisture created must have fooled the probe jack. Five minutes with a blow dryer directed at the probe jack did the trick. Thanks to all! You saved our Xmas. Baking can continue.

Chris
December 2014

With regards to KitchenAid Model KEMS307GBLO (micro/convection oven), access the back of the control panel and cut wires P5-4 and P5-5. The wires are labeled. According to the schematic, these are the pinouts for the "Meat Probe," and, "Meat Probe Chassis Ground." This will permanently render the probe inoperable, and all the aggravation that is causes.

Please proceed at you own risk. This was a fix for us using a schematic we found inside of the unit. NOTE: This fix is for a different model. Check your schematic (found behind the the control panel) to confirm which wire controls your probe.

On model 307, to gain access to the back of the control panel, simply remove the two vertical trim pieces that run the length of the appliance. They are secured by one screw each towards the bottom of the trim piece. Access to that screw requires opening the oven door. Once the screws are out, pull downward and outward on the trim pieces and they will separate from the body. Then, see the screws that hold the control panel in place. There's one on each side of the panel, facing outward. Once you remove those screws, the panel will fall forward gently. The P5 wires above are found at about the mid-point of the control panel.

Tired of Probe Problems
November 2014

Worked for me too. Convection roasted a turkey, lots of steam... 160 and 350 for an hour in my case fixed it.

C
November 2014

Bless you for solving this issue for us. After searching the house for the stupid probe and not finding it, I googled the issue. You saved us lots of $$$$ ! Heating it up cleared the probe problem. Thank you!

Lee in CA
November 2014

I have a Kitchenaid KEBS278SBL00 dual convection oven and it frequently has the same problem. I think I'll try to contact Kitchenaid to see if they can come up with some permanent fix for this obviously common problem.

By the way everyone is describing the problem, it indictates to me that when a probe is not inserted, the probe input to the controller board(s), is open circuit. That means that any moisture can create enough of a circuit path to make the controller think a probe is plugged in. I am an electronic engineer of 30+ years, and this is a fundamental design flaw. A proper design would use a probe connector that when a probe is not plugged in, closes a secondary set of contacts, and tells the controller that a probe is NOT plugged in.

This is a poor design by Kitchenaid, and they owe it to their customer to provide a proper fix.

Joe Delasko
September 2014

Turn on the oven without anything in it and run it at above 350 for enough time to dry out the oven. The probe issue should disappear with the oven moisture.

George Cheney
August 2014

Thanks to the kind fellow who has provided the simple answer to KitchenAid's ridiculous temp probe problem. This has come up for us about every other year, or exactly the time it takes to forget the solution! I am now taping this to the oven...

George Cheney
August 2014

Thank you so much to everyone who wrote on this!! Totally fixed my problem. We have had issues with the door not shutting all the way and the light coming on; have had to get a repair guy out here who has been less than helpful and I thought, "this guy now has caused another problem i'm going to have to get fixed" but it was simple to fix as you all posted. thanks again!

ao
August 2014

My Kitchenaid is a model KG?????-something according to the manual, and I am having the same problem w/ the "phantom" probe stopping me from being able to use my oven... i've tried setting the phantom probe to 160 degrees and then setting the oven to bake at 400 degrees, etc - HOWEVER, the kicker is, when the "Start?" prompt scrolls on, and I hit the "Start" button, it doesn't... Instead, it changes the temp to 06 degrees, then 36 degrees when I try to hit the start button again, etc...
Bottom line: I'm still stuck & cannot get the oven to turn on/heat up/work at all - it never actually turns on in order for it to heat up & dry the probe sensor out, just continues to keep me going in circles asking for the probe temp or to remove probe (which we have never ever used and in fact does not exist...) HELP PLEASE?! Thoughts? Thanks very much

Allison
July 2014

use hair dryer to dry the probe hole. It may need to dry for around 20 minutes.

David
July 2014

Same issue as everyone below has experienced. I purchased a KitchenAid double oven, model KEBS208 in Nov 2007. It wasn't installed until almost a year later. No problems with it until today - May 5, 2014. After baking some vegetables, left the oven door open for 15 - 20 minutes to let moisture out and then closed it. Shortly after the door was closed, the request to "enter probe temperature" or "remove probe" came on. I Googled the problem and saw that I wasn't the only person with the same problem. I followed the advice to, basically, evaporate the moisture from the probe hole. I set the oven temperature at 400 deg F and timed it for 20 minutes. The oven is OK now.

Pam
St. John's, NL
May, 2014

Pam
May 2014

I have the same problem since yesterday, after we used with a pan with water into it. I was reading, your coments and suggestion offered by Angela, but I can not find the probe hole to cover it. Please, help me.

Ani Aponte
April 2014

Same problem. Must have been the Turkey yesterday. Set the temp to 160 at 350 degrees. When it said LO temp, I hit off and it was fixed. Thank you, thank you for your suggestion. No need for the service guy and expense. I have saved this site in favorites for future use, if needed. Thanks!!!

Anne
December 2013

I had the same problem with my KITCHEN AID, the oven keeps beeping, and displays on the screen " Enter Probe Temp" or "Remove Probe" but we don't even have a probe. I followed the advices on this site (set probe temp at 160 and bake at 350 for 30 minutes) and it did solve the problem! Thanks to all who did share their experience!

Pierre
December 2013

Thank you everyone for posting solutions to the error message "set oven probe temp"! I have regained my sanity, which was slipping away after just 30 minutes of incessant beeping and fruitless searching of my appliance manual and kitchen aid website. Turning the oven on 350 for just 15 minutes did the trick. The culprit- roasting two full trays of butternut squash, apples and onions. I too have never even used the probe. Many thanks !

SoCal Gal
December 2013

Patty, your solution worked perfectly on the first try. So glad we found this forum - another forum on Applicanceblog.com calls for very time consuming repair. Glad I kept searching and I'll be sure to come back here in the future (although hope there's no more need).

Michael
December 2013

I had the same problem today after spilling copious amount of turkey broth from boiled turkey carcass onto the stove top and down its side. I tried unplugging & plugging the unit back in, but the probe light came back on. I was all worried until I found this thread... and problem is now solved.
I set probe temp to 180 & oven temp to 450, let unit heat up until probe message beeped and said 'plug probe in'. I couldn't find my probe, so instead just turned the unit off. Bingo, no probe light on. I am so thankful for people taking time to write an answer to this problem.
Thank you everyone!!

Patty
November 2013

I had the same problem last night after I roasted my turkey. Thanks a lot for this thread, the set probe temp beeping got fixed after set the oven to 165/500 with probe inserted.

I guess the issue is because I left my turkey sitting inside the oven yesterday for too long time which caused moisture.

David Z
November 2013

I had the same problem with the probe after I cleaned the oven with Easy Off (and I never in eight years have used the probe). I set the probe temperature to 200 degrees and the bake temperature to 400 degrees. The first time I did this, the probe light didn't go off. So I took my hair dryer and (on high heat) aimed the dryer hot air into the probe socket in the oven, did this for a minute or so. Then I repeated above once, used the hair dryer again, and then left the oven door open. The problem was fixed--there must have been moisture in the probe socket. I'm so glad I found this web site and didn't have to call a repair man! :0)

Elena
November 2013

Wow! I had the same problem with the 'probe' even though I never used it ... I followed the advice here and voila, the problem went away. Surely saved me $100's...thank you so much for hosting this site.
Does anyone know if there is something that could be inserted into the probe input that would prevent the moisture from entering, thus preventing this problem from reoccurring?

John
November 2013

My friend Jim pointed me to this website, and it saved my life, or at least my pocketbook! The moisture in my oven from roasting 25 pounds of potatoes and leaving them in the oven overnight caused condensation galore! That must have caused the "remove probe" message. I set the probe temperature at 160, and the oven temperature at 400, and left it on for 30 minutes. No more "probe" message! Thank you so much for the great advice!

Diane
October 2013

Yes, it worked. I set the probe temp to 150 degrees and then set oven temp to 400 degrees. I left oven on for 20 minutes and then turned it off. The problem has blessedly gone away. Whew!

Jennifer
September 2013

Thanks everyone for your help. We are having this problem right now and I have just followed the advice to set probe temp and set oven temp at 400 degrees. Our problem has happened 2 years in a row while drying out Roma tomatoes which are very moist. I had 2trays of these tomatoes in the oven and the steam was pouring out for the past several hours. When they were done, I turned off the oven and the probe light came on. Moisture certainly seems to be the problem and I look forward to getting my oven back to normal. last year the problem went away after 3 days but we had no idea why. At his year we were set to call a repair man or even buy a new oven, so thanks again for the great advice. The internet is certainly a wonderful thing.

Jennifer
September 2013

After baking. our kitchen-aid oven wouldn't turn off and displayed " Enter Probe Temp" I never used the probe...I couldn't turn the oven off!! I was puzzled, I checked the oven manual and couldn't find an answer, and I didn't find directions where to insert the probe in the oven, I was disappointed. I searched the internet, and did what some people suggest on this web sight.....I interd the probe temp to 160 and bake at 450 and let the oven run for 15 minutes, then I turned the oven off, it worked :-) thank you guys for the tips :-)
what I think happens I had too much steam when I baked, I used a pan filled with water to bake evenly, I think that creates a problem, too much moister, I think!
thank you guys

Internet fan
September 2013

After wiping down the oven (KEBC247KS) after a clean cycle, my oven had the probe symbol displayed. I didn’t even know what it was! I used the method below, set the phantom probe to 160 and the oven 375. I ran the oven until it prompted me to insert the probe. I ignored the prompt and let it run and after 15 min turned the oven off. All is well now. Thank you so much for the great responses!

Elizabeth
May 2013

I over boiled a pot of water and the insert temperature probe message appeared. I followed instructions from a post below and it worked. First I set the probe temp to 180 and then i set the oven temp to 450, left it for half an hour, turned the oven off and the insert probe message went away. back to normal.

Lia
May 2013

Thanks, this worked for me.

I had a lot of water boil over the pot (on the stove) last night, and this morning the oven was acting as if the probe was inserted (it wasn't inserted - and I have not seen the probe for years).

So I set the probe temp to 180, after setting the oven to 450, and in about 10 minutes the oven was asking me to insert the probe, which means the oven was now working correctly.

Just to make sure it was completely dry, I ran ran the oven thru a cleaning cycle, after the problem cleared.

Wayne
January 2013

Right. It's happening to us now. The whole thing is not operable, so setting the oven is out. We are waiting. Tomorrow morning if still stuck, we will try the blow dryer.
Can't see the Model number. A free standing with warming tray and panel at front.

Joseph H
December 2012

If your having a problem with your wall oven,and it keeps reading to enter probe temperature and probe may not even be plugged in. Pull out a hair dryer open your microwave and blow air just bellow were the menu screen is continue for about 20 seconds, and presto your screen will reset. I had tried all the other suggestions bellow with no results, this worked immediately, Good Luck all.

Kevin
December 2012

Good luck with this. Shortly after purchacing mine mine started scrolling "enter probe temp___ or remove probe. This was after I had shut off the oven and cooking complete. In some cases I had not even used a probe. Tried to correct by inserting the probe and removing...no help...tried shutting off the breaker to the ovens and try to reboot...same message reappeared. Tried to enter a Temperature but say for 325 it would not let me put in but two numbers 32.would not take the 5. Under warranty the wiring harness, control board probe jack and who know what else was replaced. No problems for over 2 years and now it has started doing it again!!! Usually if left alone it will clear itself after about 3 hours. HOWEVER on one occassion it cleared itself and oven was off but strated scrolling again on its own then cleared it self again after an hour. PROBLEM WITH THIS IS WHEN THIS IS HAPPENING THE OVEN IS NOT OPERABLE. I DO NOT THINK KITCHENAID EVEN UNDERSTANDS THIS!!!!!!!!!!!!!!!!!

R. Salem
November 2012

I did as others suggested in this thread, but with no success: I still get the probe message.

My experience with Kitchen Aid appliances has been all bad. I got rid of my Kitchen Aid microwave and I would NEVER buy another Kitchen Aid appliance again.

Daniel B.
November 2012

Thanks so much for the info. This problem had been driving me crazy for a couple of days, but setting the probe temp to 160 (with no probe inserted) and running the oven on convection bake at 450 for a bit dried everything out and cleared up the issue.

Makes you wonder how many people spent the $500 on a new GUI for the oven when all they needed to do was dry it out.

Fernando
October 2012

Had probe temp prompt come on after steam in oven. Could not get oven to turn on or prompt to clear. Reset via breaker and no luck and then found this site. Thanks so much!!! Did probe temp at 150 and set oven to 400 for 15 minutes and problem solved!!!
What did we do before the internet? Thanks for posting the solution! I needed my oven this weekend and you saved me a service call.

Michelene
June 2012

thank you so much everyone! true lifesavers. this happened to me and it was because water boiled over on my stovetop element and somehow triggered the probe. i set the oven to 350 and the probe temp to 130 for 5 minutes and voila, it dried out and problem solved.

Bel
May 2012

I have the same problem. I went to cook a couple of chickens using the convection roast option and the oven keeps asking me for the probe temp or to remove the probe which I did not even use. I can only enter 2 digits for the probe temp, so I keep putting in 90 degrees. However, it still wont let me turn on the oven. I am not sure what to do.

Kali X.
March 2012

Had the same problem with a KEMS308SS. It's related to moisture. We baked some vegetables which caused this to occur. Thanks to this webpage I was able to fix the issue running the oven at 400-450 for about 15 minutes.

Leo
March 2012

I have a Kitchenaid oven in the model that I believe is KERA807. I have the same problem with inexistent probe flashing on my display saying to enter teem or remove. I tried doing the following suggestions but nothing works!!! once I put the temp to 150 degrees F and in bake for 350 degrees it shut off automatically and the problem still hasn't gone away. Any other suggestions?

Thanks

Vanessa
January 2012

This happened to me with model KEBS277SBL04 (double electric, convection on top--and no temperature probe) today. I was freaking out since Christmas dinner for 20 is at my house next Sunday. Oven repairs are not on the schedule -- or in the budget! I tried the fix suggested below--set the probe temperature at 150 (even though there isn't a probe) and set the oven on 350. It's heating now, and I fully expect the probe prompt to stay gone. Thanks so much! This was like a bonus Christmas present!

Sherry Co
December 2011

This is a most annoying problem that I have encountered several times now over the last few months. Each time it happens I set and reset the temperature several times at 375degrees. After several tries the probe error disappeared. I live in Florida so it could be a problem with moisture .. not sure. Mind you, I have had my oven since the summer of 1998 and it is still working well, save for this recent issue so I can hardly complain!

Sherry
December 2011

After Thanksgiving dinner, while cleaning up we noticed our 3yr old double oven (micro-convection) Kitchen Aide Superba KEMS378S message screen prompted us to - Set Probe Temp or Remove Probe - we were at a lost, we have never actually used the probe.

We tried it all, touched every combination of buttons, turned off the circuit breaker, inserted the probe and started the oven (in our case the display showed the probe already at "Lo"), removed the probe, even read the instruction manual, (page 14 re the probe cooking did let us know what to set the probe at, but was no help fixing the problem). Nothing to do but Google. or eeks wait to call a service person during a holiday weekend. We read the answer here and Voila!

We set the probe to 130 and then set the oven to bake at 350 degrees, 40 minutes later we turned off the oven and message screen reset to its normal display.

What we believe caused the sensor to error is the last hour of browning our turkey uncovered sent steam directly up to the senor. So the explanation of the sensor picking up too much moisture makes perfect sense!

Charley and Laura
November 2011

I am having the same problem but the solutions don't seem to work for me. I entered the probe temp of 80 degrees and it won't let me enter anything else. It just beeps and gives me the error message again. I can't even get it to a bake temp.
any other suggestions?

Connie
September 2011

wow thanks! worked for me too!

Big Lou
September 2011

fyi - if it doesn't take temps between 150 and 190 F, try anything between 60 and 80 C - somehow I switched the setting from Fahrenheit to Celsius and it wouldn't accept 3 digits but worked on 70 deg C. Thanks for all the tips guys, this really helped.

ThankYouAll
August 2011

Same problem with probe configuration dialogue not turning off on a recent Kitchen Aid oven KBHS179.

What worked for me was running the oven on Bake for about a half hour at 350 degrees without the probe inserted in its oven jack and activated as others have suggested at 150 degrees.

I suspect the problem is related to moisture and drying out the oven is the remedy. I say that since the problem oven is in our vacation house in Door County Wisconsin where it can get humid with August heat. We had not used the oven for several months when the probe message just suddenly appeared.

Paul L
August 2011

yes, our oven has the same problem that you described. The oven turned off when we were using it. The probe picture is still on after 24hours.

Linda
January 2011

Amazing! Thank you everyone. Did the same thing after cooking Christmas turkey. Probe light came on. Read these responses and entered 130 degrees in probe temp, set bake at 350 and waited ten minutes. Once probe temp hit Lo, turned off and voila! Everything back to normal!!!

Geordie
December 2010

I just want to thank everyone who posted on this problem.
I had the probe malfunction right when I was getting ready to bake the Christmas desserts! We were able to read these responses and fix the oven. So thanks to all of you, Christmas is saved.

Janice
December 2010

This occurred yesterday, the day before thanksgiving. My wife was proofing bread all morning with a tray of water at the bottom. So it must be a moisture thing. Cannot be corrosion since the oven is new. Following advice on this site, I entered a number between 130 and 190, set the oven for 350, and after a few minutes it corrected itself.

John
November 2010

Same problem. Mine is an undercounter installation of a single wall oven. It appears that water spilled on the counter had leaked into the fron panel overnight and the moisture had confused the electronics.
Turned it onto 300 for a while and dried it out.
Problem solved!

relieved
October 2010

Once again the wonders of KitchenAid have shown what a customer friendly company they are. The easy fix is to install the flip cover over the probe hole that the older KitchenAid ovens had. We had a KitchenAid for 8 years and never had this issue. We've had this wonderful oven for four years and whenever we start cooking inside (autumn is here and the grill will be used less frequently) it starts again with the "Set Probe Temp or Remove Probe" (which isn't inserted to begin with). I am at the point where I am going to buy a new oven and it sure won't be KitchenAid or anything remotely associated with them. And I intend to tell everyone I can about their crappy design and customer service. When the answer to us consumers is to unhook the probe / disconnect the wiring - then it is time that they go broke, because that is just a bunch of crap.

Jerry
October 2010

For "Enter probe temperature or remove probe" :
If you refer to your manual, the probe can only take a temperature range from 130 to 190. So, in order to eliminate the probe request, just enter any number between 130 and 190. My oven does this from time to time, and the first time was very frustrating because the manual doesn't drive the point home very well, so I started entering temps from 450 down in increments of 50 and when I got to 150 it accepted. When I re-read the manual (page 15) the number I entered made sense. I hope this helps!

OCBrad
September 2010

Same problem. Probe light on for no reason. Very humid for past 1 week which is unusual. Heated oven up to 350 for a few minutes and the probe light went off. Thanks for the tips!

Lynn
July 2010

Different oven (KEBS107SSS), but same problem after powering it up for the very first time. It was cold outside when it was delivered, so bringing it inside could have condensed cold air and could be causing the problems. Condensation and electronics don't play well together! My oven will ask me to enter a temperature for the probe or remove it, but won't let me enter more than 2 digits. If I leave it alone for more than about 10 seconds error code F3E3 will display and I can do nothing. Turning it off for a while will reset to the 'enter temp or remove probe' screen.

If I quickly depress bake or another function after turning the oven back on (once it's been off a while), the oven will heat properly to the selected temperature. Once I depress 'off' it will default back to the enter temperature problem. All this without a probe inserted.

Maybe once it's been in the house for a while it will correct itself before the repair tech works on it in a week.

james
February 2010

Different problem entirely. Probe simply does not work. push it in the jack and get no reading on front. Kitchen aid willing to sell me a new one for $60 but no return and no guarantee that is the problem. I like the probe-it is great for meats. Anyone have this issue?

john
January 2010

Just turn on the oven to the temperature it reads, let the oven run and it will turn reset.

Michael
January 2010

Like Ray before me, I got the same spurious "probe" error message and it prevented me from using the oven. I didn't have a probe, so I set the temperature as suggested, turned the stove on (325F) for about half an hour. When I turned the stove off, the probe indicator and message went away.

Beric
January 2010

My exact problem and I fixed it just like the suggestions. I had to enter a temp probe temperature so I chose 150. I did not have the temp probe inserted. Then I chose "bake" at 450 and start. The oven heated to 450 with the temp probe reading "lo." I let it stay on a few minutes but the "lo" did not go away. I thought it did not fix it. However, when I pressed "stop" everything turned off and there was no temp probe warning. Thanks guys, saved me a lot of money and trouble.

Ray
November 2009

Sunday (yesterday) cooked a roast using the probe. It was done-excellent (too) but now my oven is stuck on "insert probe or press cancel." To say the least, the latter does not work. I am hoping that one of these remedies works-has anyone else tried any of these suggestions?

Rico
October 2009

Message: "Enter probe temperature or remove probe" when no probe is inserted in probe jack.We just expierenced this problem since purchasing a KEMS308SS00 in July of 2007. I plugged in the probe and hung it outside the door, entering a probe temperature of 160. Then turned on convection bake and set to 450. When that temperature was reached (the probe icon was still showing), I opened the door and unplugged the probe (use an oven mitt to do this). The unit asked for probe temp to be set once, then it didn't, then it asked again then finally went to normal all in the course of a couple minutes. Obviously, the moisture that was in the probe jack was drying out during this time. After cooling, the oven works as before.

Rick
September 2009

I just had this happen today after manually cleaning my oven (automatic cleaner mechanism broken). The front panel display was 'pull probe out' and the oven would not turn on. I took my blow dryer and blew air toward the probe for a few minutes then tried the oven again. It turned on but the icon on the front changed to 'push probe in'. I did then re-pushed the start button to 450 and it worked!

LM
August 2009

Hi people. Seems like there is a corrosion problem with the probe connector. Advice is to remove the probe wiring/harness. You won't be able to cook using the temp probe, but you'll have a reliably working oven. Here's the link:

http://www.applianceblog.com/mainforums/showthread.php?t=12867

Only attempt if you are a DIYer and turn off the POWER!!!

P.S, If you have a loud humming noise when the wall oven is heating up.. you can find the fix here:

http://www.whirlpoolparts.ca/pnit_results.php#

Enjoy!

sinnedkong
June 2009

I have had my oven for almost 3 years now and just had this happen today. After searching the internet I tried the solution given here about plugging in the probe, setting the oven to 450 degrees and letting it go for awhile. This worked and the oven is now fine. It has been very humid here in Maryland and we did not have the ac on so it looks like the moisture issue could be valid in this instance especially considering it then went away once the oven was heated up (and consequently drier).

Denise
June 2009

same problem only thanksgiving. For a short term fix I put in the probe and hang it outside the oven which tricks the oven to stay on because leaving it inside the oven causes it to shut off at a max. temp. lots of luck K.A. cooks

alan
May 2009

I have a possible answer!!! We had the repairman out...of course, our oven started working before he made it out. But he said the probe hole can get moisture in it and cause the oven to not work until it evaporates. Which sorta explains why several of us had it start working again. It looks like several people also had it happen Christmas, probably with lots of stuff in the oven for a long time, creating lots of moisture.

So, I think we are just going to tape over our probe. We never use it, and if my options are losing that feature so the oven will operate, well I am ok with that! Hope this helps someone out there!

AngelaB
January 2009

Happened to me Dec. 25, 08. Tried cutting power to unit, putting ipod jack into probe input. Could not clear probe error.
On Dec. 27th I, pushed regular bake, 450 temp, start. When oven reached temp the probe error corrected itself.
Oven works fine again.

Ron
December 2008

Same problem Christmas Day, cooking turkey. Happened last year and fixed itself a couple days later. I think grease in jack is giving false reading. I tried the input from ipod head phones, but no fix yet.

Ron
December 2008

Anyone have any luck with resolving this? NOT good timing, for this to happen Christmas Day!!!!

AngelaB
December 2008

Sorry, no advice from me. I too am looking for an answer as my Kitchen Aid stove suddenly displayed "Remove Probe" last night and I haven't been able to turn it on since, even after unplugging it for extended periods. I bought my first Kitchen Aid stove in 2000 and after 3 years the oven door froze shut after cleaning.
The repair man came, concluded the computer panel was shot and eventually I was offered the new model for $600. I had no choice. Now 5 years later I have the sinking feeling that my second $2000 oven will again need replacing. I'll keep you posted. Needless to say, stay away from Kitchen Aid stoves and if I had it do all over again, I'd completely avoid computerized units and opt for a higher end old school model.

David J.
Toronto

David J.
December 2008

I have the same problem with my kitchen aid model, the oven keeps beeping, and displays on the screen " Enter Probe Temp" or "Remove Probe" but we don't even have a probe. I have searched the internet for answers, but only found the same problem over and over again. Seems like faulty circuit, so Kitchen Aid has some explaining to do...

Unhappy Kitchen Aid Customer
September 2008

To add an answer, click here    

Add An Answer Form

Add your answer using the form below ...

The question: Kitchenaid KEMS377 Oven Probe Problem?
Your answer:

(Add your answer here. Try to include as much detail as possible.)
Your name:

(Enter your name as you wish it to be displayed.)
Other questions in this category - Kitchen Appliances, Microwaves
Where can I find the model # on Kitchenaid slide-in range?

I just bought a used Kitchenaid slide-in range and can't find the model #. I wanted to get a manual on-line. I looked all around and inside. It's also showing "set probe temperature or remove probe" on panel. I can't see a probe and can't remove this directive and the constant beeping is irritating....

Click here for the repair.
How to fix a light bulb in oven?

how do you replace a light in a Kitchenaid free standing oven model #KDRP407HSS13...

Click here for the fix.
Light replacement for the microwave?

The light went out in our kitchenaid microwave oven and i don't remember where the used to come from. I see what looks like a bulb in the top center, but when i try to take it out, it doesn't seem to come out. Am i trying to remove the wrong thing? Model number kems377gwho...

Click here for how to mend it.
replacing light bulb in kitchenaid microwave 378KBL?

This should not be that complicated but I have spent the past 40 minutes just trying to figure out where the light is and still can't find it. Thank you so much p.s I am 78yrs old so may not have alot of time to get this fixed....

Click here for how to mend it.
How can I replace the light in my microwave?

How can I find and replace the light in my kitchenaid microwave model KCMS1555R...

Click here for the repair.
How do I change a light bulb in the kitchenaid KEMC378KSS02 microwave/oven ?

How do you change a light bulb in the kitchenaid KEMC378KSS02 microwave/oven combination...

Click here for the repair.
kitchenaid microwave?

how do you change the light bulb in my kitchenaid microwave model KCMC155JBLO...

Click here for the repair.
How to replace shelf (floor) of cooking cavity--what material?

I broke the shelf (floor) of the cooking cavity in a KitchenAid microwave--Model KCMS135S. The replacement part is no longer available through regular repair parts channels. Could a replacement be fabricated? What material? Any other ideas? Thanks...

Click here for the repair.
Fix what?
Household Appliances, Steam Cleaners - fix/mend/repair/service information
Memory, CompactFlash (CF) - fix/mend/repair/service information
Clocks and Watches, Wrist Watches - fix/mend/repair/service information
Help wanted!
Advertisements
Fixed!
I followed your instructions and got the tape out safely.

CTB
Mar 2019


Mend it
How can I fix my clutch?
All appliances!

To mend any household, kitchen, or other electrical appliance start here.

To search for repair advice click here.

To find out how to mend it click here.

Mend it
How can I repair my speedo?
Fault find
Click here to fix Ignis products.
Advertisements
Important

Attempting repairs can be dangerous.
In many instances work should only be undertaken by a qualified professional.
Ensure you have read our Small Print page before using information supplied via this website.

©  2003 vE
We use Cookies. See our Privacy Policy.