Mend Audio, In-Car Audio

Audio, In-Car Audio
Find out how to mend it for free.

Ask Question

In-Car Audio

Mend Mend Audio, In-Car Audio

2 problems Kenwood KDC-7009 & Sony CDX-CA850X?

First the Kenwood. It seems I lost all function on the face plate. It will still rotate in and out when I turn the car on and off but once it's open I cant use any of the functions. I cannot even use the buttons to put the code in after restetting it with the reset button. Is there a fix for this problem that anyone may know of.

2nd problem, i used this sony deck to replace the kenwwod when it went and know the sony is messed up also. It will not pull in any radio stations anymore. It will work once I reistall the deck after being idle for a few day/weeks but then after a day or so I have no reception again. I have had this installed in my old car and now in my new/used truck and I have the same problem in both so I know it's not the antenna. I hope someone can help with these problems. Thank You so much for your time.

Chris Strunk
May 2006
My Kenwood does the same thing. The display is dim and the buttons don't work at all. I disassembled the whole thing, disconnected everything I could find, cleaned it, blew out dust, checked for loose or missing pieces... nothing. Problem persists. The fuse for the radio in the vehicle was blown, but I replaced it. Problem persists. The fuse in the stereo itself is fine, so I'm at a total loss. And to boot, Kenwood doesn't have the manual on their site for this model. If you have the manual or anything else that will help, please share it with me... nicklessig@yahoo.com

Nick Lessig
July 2006
first off im assuming the kenwood is a mask? if so u don't have any contacts to clean, if this is the case it sounds like the ribbon connecting the front has come unplugged, so get your screwdrivers out and strip it down to re connect

2nd, the sony. if you lose all stations everytime you take the keys out then you definatly dont have a permanent possitive. if however it works when it feels like it then you have a knackered tuner board, (happened alot with the M610!)

I.C.E. Services. species@vodafone.net
May 2006
1. KENWOOD, CLEAN THE CONTACTS BETWEEN THE FACE PLATE AND BACK WITH "BRASSO" OR SIMILAR METAL POLISH, DONT GO MAD JUST A WIPE.
2. ALMOST CERTAINLY YOU DO NOT HAVE A PERMANENT +12V FEED, SO WHEN YOU TURN OFF COMPLETELY MEMORY IS LOST
HOPE THAT HELPS
MIKE.

MIKE
May 2006

Categories

Find out how to mend just about anything howtomendit.com for free repair help, information and advice.
Categories